2015-03-05

[RouterOS] RB450G 解決多pppoe外部ping不到問題

前面一篇 [RouterOS]-RB450G 依據內部不同ip決定不同pppoe進行連線
介紹了怎麼將內網的設備依據不同的ip設定走不同的pppor interface出去,
這樣雖然解決了出去的多pppoe需求,但是也因為建立了多個pppoe,
如果從外部ping這些pppoe建立的ip,會發現只ping的到預設的pppoe ip,
以我的例子一共建立了pppoe-out_F、pppoe-out_F_NAS、pppoe-out_S,
預設是所有內網電腦都是用pppoe-out_F上網,但也只ping到這個連線的ip,
其他的pppoe-out_F_NAS、pppoe-out_S都ping不到!


這個問題原先我也沒有很在意,當在實做VPN PPTP 連入時,
雖然VPN規劃的網段與區網相同,但怎麼樣就是ping不到NAS的內網ip,
最後在01上面請教網友後,在Mangle下針對NAS連線加入兩條規則即可,
另外一條pppoe固定ip因為沒有這樣的需求,所以沒有建立相同規則。

/ip firewall mangle
add action=mark-connection chain=prerouting comment="\BC\D0\A5\DCpppoe-out_F_NAS\B6i\A8\D3\AA\BA\B3s\BDu" in-interface=pppoe-out_F_NAS new-connection-mark=CONN_IN_pppoe_f_nas

add action=mark-routing chain=output comment="\B3W\A9wpppoe-out_F_NAS\B6i\A5X\A8\AB\A6P\BC\CBinterface" connection-mark=CONN_IN_pppoe_f_nas new-routing-mark=RM_pppoe_F_NAS passthrough=no



參考自
[研究所] MikroTik RouterOS 學習 (持續更新) #3254
電腦茶包Blog-RouterOS 2 WAN Mapping to 1 LAN,多個WAN對映到單一內部Server
MikroTik RouterOS Hairpin NAT - Pros & Cons
張貼留言